This article describes the minimum system requirements to run the Anytime Mailbox App for both iOS and Android users. 


iOS Requirements:


The Anytime Mailbox App requires iOS 11.0 or higher. They are compatible with the following iOS devices:


iPhone 5s 

iPhone 6 to 6s Plus 

iPhone 7 to 7s

iPhone 8 to 8 Plus

iPhone SE 

iPhone X

iPad Mini 2 to 4 

iPad 5th and 6th Generation 

iPad Air to Air 2

1-inch and 12.9-inch iPad Pro (1st and 2nd generation)

iPad Pro (9.7  and 10.5-inch)

iPod touch (6th generation)


To find software version installed on your device, go to Settings > General, then tap About.



Android Requirements


The Anytime Mailbox App requires Android 6.0 or higher


To find software version installed on your Android device:


  • Open your phone's Settings menu.
  • In the menu, select and tap "System."
  • In the System menu, likely at or near the bottom, tap "System Update." It should tell you what version of Android your phone is running.


To download the application please click link below:


Renter App iOs App Store link:  https://apps.apple.com/us/app/anytime-mailbox-renter/id1107039332 


Renter App Play Store Link: https://play.google.com/store/apps/details?id=com.anytimemailbox.renter&hl=en&gl=US 


If you still need assistance, you can reach us at the following channels;


Call us - https://www.anytimemailbox.com/contact

Live Chat - https://www.anytimemailbox.com/

Email: help@anytimemailbox.com